Форум Kerio-rus

Вернуться   Форум Kerio-rus > Продукты > Kerio VPN

Важная информация

Ответ
 
Опции темы
Старый 06.10.2014, 06:45   #1
metallicswar
 
Аватар для metallicswar
 
Регистрация: 26.09.2013
Сообщений: 15
По умолчанию Зависает l2tp подключение

Еще раз добрый день.

Есть vpn подключение к микротику с керио, в один прекрасный момент на микротике отключается интернет и подключение отваливается. Керио в попытках подключиться как то хитро зависает, пишет в статусе интерфейса l2tp "подключение" и висит. И висеть может сутками, пока либо керио не ребутнёшь, либо подключение не пересоздашь. Никто с такими граблями не сталкивался? Как это лечить?
metallicswar вне форума   Ответить с цитированием Вверх
Старый 12.10.2014, 07:52   #2
EnMan
Телепат-тугодум
 
Аватар для EnMan
 
Регистрация: 11.05.2006
Адрес: Lipetsk
Сообщений: 4,578
По умолчанию Re: Зависает l2tp подключение

Если туннель зависает, данные не бегают внутри, но статус "подключен" лечить так:
Код:
/tool netwatch
add down-script="/ppp active remove [find name=username]" host=XXX.XXX.XXX.XXX interval=15s
где
username - имя вашего пользователя устанавливающего подключение на microtik
XXX.XXX.XXX.XXX - серый адрес внутри локальной сети за Control

В вашем случае я бы попробовал в момент когда туннель не может создаться - перегрузить именно тик. И если это помогает, то тем же netwatch чистить конекшен тракинг на микротике.
Код:
/ip firewall connection tracking
set enabled=no
:delay 3
set enabled=yes
:local message "Contrack cleared"
__________________
керио
EnMan вне форума   Ответить с цитированием Вверх
Старый 13.10.2014, 03:06   #3
metallicswar
 
Аватар для metallicswar
 
Регистрация: 26.09.2013
Сообщений: 15
По умолчанию Re: Зависает l2tp подключение

EnMan,
Я так понимаю, это всё выполнять на miсrotike? Но виснет то подключение со стороны kerio, и микротик можно хоть целиком ребутать - бесполезно, он ни сном ни духом, что к нему кто то пытается подключиться.
Или я чего то не понимаю?
metallicswar вне форума   Ответить с цитированием Вверх
Старый 13.10.2014, 09:09   #4
EnMan
Телепат-тугодум
 
Аватар для EnMan
 
Регистрация: 11.05.2006
Адрес: Lipetsk
Сообщений: 4,578
По умолчанию Re: Зависает l2tp подключение

Если ребут тика не помогает, то я бы начал с дебаг лога и на стороне Control и на стороне Mikrotik
__________________
керио
EnMan вне форума   Ответить с цитированием Вверх
Старый 24.01.2019, 23:50   #5
beria
 
Аватар для beria
 
Регистрация: 11.01.2011
Адрес: Минск, Беларусь
Сообщений: 15
По умолчанию Re: Зависает l2tp подключение

Подниму тему. Столкнулся с такой же ситуацией. Версия Kerio - 9.2.8 build 3061 (пробовал и на 9.26 - одинаково). Тоннель между Kerio и Mikrotik (l2tp). Если на стороне микрота пропадает интернет или просто принудительно дропнуть пару раз сессии, на стороне Керио l2tp клиент виснет в статусе "подключение". Помогает только ребут керио.


Debug в керио выглядит так:
beria вне форума   Ответить с цитированием Вверх
Старый 24.01.2019, 23:56   #6
naliman
Администратор
 
Аватар для naliman
 
Регистрация: 19.06.2006
Адрес: оттуда
Сообщений: 14,361
По умолчанию Re: Зависает l2tp подключение

beria, камрад, почитай здесь: [Для просмотра данной ссылки нужно зарегистрироваться]


если вдруг через несколько дней ты не обнаружишь своего сообщения, значит переезд по каким то причинам не состоялся и мы вернулись на прежний хостинг
в этом случае задай вопрос снова
__________________
Общество свободных людей – совсем не то же, что толпа одиноких расчётливых эгоистов, безразличных к общему благу
naliman вне форума   Ответить с цитированием Вверх
Старый 28.01.2019, 21:17   #7
Ruza
 
Аватар для Ruza
 
Регистрация: 12.03.2007
Сообщений: 1
По умолчанию Re: Зависает l2tp подключение

Цитата
Сообщение от beria Посмотреть сообщение
Подниму тему. Столкнулся с такой же ситуацией. Версия Kerio - 9.2.8 build 3061 (пробовал и на 9.26 - одинаково). Тоннель между Kerio и Mikrotik (l2tp). Если на стороне микрота пропадает интернет или просто принудительно дропнуть пару раз сессии, на стороне Керио l2tp клиент виснет в статусе "подключение". Помогает только ребут керио.


Debug в керио выглядит так:
Аналогичная фигня. При обрыве сессии l2tp интерфейс залипает в состоянии "connection".
Помогает перезагрузка или пересоздание интерфейса. Вычитал на руборде что человек откатывается на 9.2.1 из-за этого но пока сам не проверял.

Последний раз редактировалось Ruza; 30.01.2019 в 00:33.
Ruza вне форума   Ответить с цитированием Вверх
Старый 14.04.2019, 20:05   #8
dimajak
Песака
 
Аватар для dimajak
 
Регистрация: 31.03.2006
Адрес: Воло
Сообщений: 68
По умолчанию Re: Зависает l2tp подключение

Аналогичная ситуация, зависает L2TP подключение к провайдеру. Может сутки проработать, а может и через 4 часа зависнуть в состоянии "Подключение".
Какой объём оперативной памяти вы выделяете для виртуальной машины с Kerio Control ?
__________________
Человек ко всему привыкает, даже к виселице: подергается, подергается и успокоится...
dimajak вне форума   Ответить с цитированием Вверх
Старый 14.04.2019, 21:46   #9
exchar
Администратор
 
Аватар для exchar
 
Регистрация: 21.04.2008
Сообщений: 3,371
По умолчанию Re: Зависает l2tp подключение

Цитата:
Сообщение от dimajak Посмотреть сообщение
зависает L2TP подключение к провайдеру. Может сутки проработать, а может и через 4 часа зависнуть в состоянии "Подключение".
попробуй добавить правило
группа инет-интерфейсов -> фаер, разрешить GRE
Цитата:
Сообщение от dimajak Посмотреть сообщение
Какой объём оперативной памяти вы выделяете для виртуальной машины с Kerio Control ?
системные требования к контролу есть на оффсайте керио
я знаю, что они 80% времени там недоступны, но все же!
__________________
"Помогая ленивым людям, ты помогаешь им сесть на твою шею" Сян-Цзы
exchar вне форума   Ответить с цитированием Вверх
Старый 15.04.2019, 03:11   #10
dimajak
Песака
 
Аватар для dimajak
 
Регистрация: 31.03.2006
Адрес: Воло
Сообщений: 68
По умолчанию Re: Зависает l2tp подключение

Цитата:
Сообщение от exchar Посмотреть сообщение
системные требования к контролу есть на оффсайте керио
CPU: 500 MHz, Memory: 2 GB RAM.
Выделено 2048 КБ. Добавил ещё 256 МБ. Буду смотреть.
Провайдер рекомендует перейти от L2TP на PPPoE протокол.
Соглашаться?
__________________
Человек ко всему привыкает, даже к виселице: подергается, подергается и успокоится...
dimajak вне форума   Ответить с цитированием Вверх
Старый 15.04.2019, 08:54   #11
exchar
Администратор
 
Аватар для exchar
 
Регистрация: 21.04.2008
Сообщений: 3,371
По умолчанию Re: Зависает l2tp подключение

Цитата:
Сообщение от dimajak Посмотреть сообщение
Провайдер рекомендует перейти от L2TP на PPPoE протокол.
Соглашаться?
как-то с выбором трудно, не находишь? предлагают - попробуй, все равно на текущем работать нормально нельзя.
только правило с входящим gre тоже поставь для PPPoE варианта
__________________
"Помогая ленивым людям, ты помогаешь им сесть на твою шею" Сян-Цзы
exchar вне форума   Ответить с цитированием Вверх
Старый 17.04.2019, 11:15   #12
Maki
 
Аватар для Maki
 
Регистрация: 16.04.2019
Сообщений: 2
По умолчанию Re: Зависает l2tp подключение

Такая же ерунда. Приходится пересоздавать соединение. Правило с GRE не помогло.
Maki вне форума   Ответить с цитированием Вверх
Старый 17.04.2019, 11:54   #13
exchar
Администратор
 
Аватар для exchar
 
Регистрация: 21.04.2008
Сообщений: 3,371
По умолчанию Re: Зависает l2tp подключение

пытай провайдера насчет исправности его оборудования
а вообще интересен дамп трафика незадолго до падения
да и журнал debug kerio в помощь, поставь там нужные галки
__________________
"Помогая ленивым людям, ты помогаешь им сесть на твою шею" Сян-Цзы
exchar вне форума   Ответить с цитированием Вверх
Старый 23.04.2019, 17:28   #14
Maki
 
Аватар для Maki
 
Регистрация: 16.04.2019
Сообщений: 2
По умолчанию Re: Зависает l2tp подключение

Вот такое пишет в логах:

Код:
[23/Apr/2019 14:45:37] {l2tpd} xl2tpd[6283]: result_code_avp: avp is incorrect size.  8 < 10
[23/Apr/2019 14:45:37] {l2tpd} xl2tpd[6283]: handle_avps: Bad exit status handling attribute 1 (Result Code) on mandatory packet.
[23/Apr/2019 14:45:37] {l2tpd} xl2tpd[6283]: call_close: Call 21164 to 89.xxx.xxx.xxx disconnected
[23/Apr/2019 14:45:37] {l2tpd} xl2tpd[6283]: result_code_avp: avp is incorrect size.  8 < 10
[23/Apr/2019 14:45:37] {l2tpd} xl2tpd[6283]: handle_avps: Bad exit status handling attribute 1 (Result Code) on mandatory packet.
[23/Apr/2019 14:45:37] {ddial} PPP Server IP 89.xxx.xxx.xxx unregistered, deleting route
[23/Apr/2019 14:45:37] {ddial} Log file for interface ppp121: ttl was set
[23/Apr/2019 14:45:37] interface "89.xxx.xxx.xxx" is DOWN
[23/Apr/2019 14:45:37] {ddial} DNS cache flushed
[23/Apr/2019 14:45:37] Service "DNS UDP" bound to address 192.168.3.2 stopped
[23/Apr/2019 14:45:37] Service "DNS TCP" bound to address 192.168.3.2 stopped
[23/Apr/2019 14:45:37] {l2tpd} l2tp state changed: Error: Unknown error (-1)
[23/Apr/2019 14:45:37] {l2tpd} Restarting l2tp in 1s (1 -> 0)
[23/Apr/2019 14:45:37] {ddial} Line "89.xxx.xxx.xxx" dialing, found static route "avangard" (192.168.1.0/255.255.255.0) for packet from Main 4, proto:TCP, len:52, 192.168.4.9:56252 -> 192.168.1.5:443, flags:[ SYN ], seq:2160218964 ack:0, win:8192, tcplen:0.
[23/Apr/2019 14:45:37] {ddial} Log file for interface ppp121 successfuly created
[23/Apr/2019 14:45:37] {ddial} Ras Dial: '89.xxx.xxx.xxx' resolved as 89.xxx.xxx.xxx
[23/Apr/2019 14:45:37] {vpntunnel} getId() - tunnel ""(client) has id 0
[23/Apr/2019 14:45:38] {vpntunnel} Last message repeated 5 times
[23/Apr/2019 14:45:38] {l2tpd} l2tp state changed: Starting
[23/Apr/2019 14:45:38] {l2tpd} xl2tpd[19327]: IPsec SAref does not work with L2TP kernel mode yet, enabling force userspace=yes
[23/Apr/2019 14:45:38] {l2tpd} xl2tpd[19327]: setsockopt recvref[30]: Protocol not available
[23/Apr/2019 14:45:38] {l2tpd} xl2tpd[19327]: This binary does not support kernel L2TP.
[23/Apr/2019 14:45:38] {l2tpd} xl2tpd[19327]: xl2tpd version xl2tpd-1.3.6 started on control-o PID:19327
[23/Apr/2019 14:45:38] {l2tpd} xl2tpd[19327]: Written by Mark Spencer, Copyright (C) 1998, Adtran, Inc.
[23/Apr/2019 14:45:38] {l2tpd} xl2tpd[19327]: Forked by Scott Balmos and David Stipp, (C) 2001
[23/Apr/2019 14:45:38] {l2tpd} xl2tpd[19327]: Inherited by Jeff McAdams, (C) 2002
[23/Apr/2019 14:45:38] {l2tpd} xl2tpd[19327]: Forked again by Xelerance (www.xelerance.com) (C) 2006
[23/Apr/2019 14:45:38] {l2tpd} xl2tpd[19327]: Listening on IP address 0.0.0.0, port 1701
[23/Apr/2019 14:45:38] {l2tpd} l2tp state changed: Running
Соединяюсь с микротиком в другом офисе.

Сегодня попробую до 9.3 обновиться.
Maki вне форума   Ответить с цитированием Вверх
Старый 23.04.2019, 18:43   #15
naliman
Администратор
 
Аватар для naliman
 
Регистрация: 19.06.2006
Адрес: оттуда
Сообщений: 14,361
По умолчанию Re: Зависает l2tp подключение

Цитата
Сообщение от Maki Посмотреть сообщение
Сегодня попробую до 9.3 обновиться.
там есть фикс, да, попробуйте
__________________
Общество свободных людей – совсем не то же, что толпа одиноких расчётливых эгоистов, безразличных к общему благу
naliman вне форума   Ответить с цитированием Вверх
Старый 24.04.2019, 22:43   #16
dimajak
Песака
 
Аватар для dimajak
 
Регистрация: 31.03.2006
Адрес: Воло
Сообщений: 68
По умолчанию Re: Зависает l2tp подключение

Подали заявку провайдеру на переподключение с L2TP на PPoE. Третьи сутки без зависаний интерфейса. Это что, диверсия со стороны провайдера была?
__________________
Человек ко всему привыкает, даже к виселице: подергается, подергается и успокоится...
dimajak вне форума   Ответить с цитированием Вверх
Старый 24.04.2019, 23:05   #17
exchar
Администратор
 
Аватар для exchar
 
Регистрация: 21.04.2008
Сообщений: 3,371
По умолчанию Re: Зависает l2tp подключение

Цитата:
Сообщение от dimajak Посмотреть сообщение
Это что, диверсия со стороны провайдера была?
если ты у себя абсолютно ничего не менял, а оно внезапно исправилось аккурат после звонка в поддержку... ясно, да? КАНЭЧНА, ЭТА СОФПАТЕНИЕ!!!11111
__________________
"Помогая ленивым людям, ты помогаешь им сесть на твою шею" Сян-Цзы
exchar вне форума   Ответить с цитированием Вверх
Старый 25.04.2019, 01:12   #18
dimajak
Песака
 
Аватар для dimajak
 
Регистрация: 31.03.2006
Адрес: Воло
Сообщений: 68
По умолчанию Re: Зависает l2tp подключение

АПСОЛЮТНА ничего не менял. А зачем, если более десятка лет безупречно работало? Я даже забыл пароль для этого форума.
__________________
Человек ко всему привыкает, даже к виселице: подергается, подергается и успокоится...
dimajak вне форума   Ответить с цитированием Вверх
Старый 24.05.2019, 21:34   #19
dimajak
Песака
 
Аватар для dimajak
 
Регистрация: 31.03.2006
Адрес: Воло
Сообщений: 68
По умолчанию Re: Зависает l2tp подключение

Сегодня поимел зависание интерфейса L2TP с удалённым офисом, которое работало десяток лет. Пришлось добавлять ещё одно соединение, перенастраивать маршруты, чтобы не перезагружать kerio 9.3
__________________
Человек ко всему привыкает, даже к виселице: подергается, подергается и успокоится...
dimajak вне форума   Ответить с цитированием Вверх
Старый 24.05.2019, 22:35   #20
exchar
Администратор
 
Аватар для exchar
 
Регистрация: 21.04.2008
Сообщений: 3,371
По умолчанию Re: Зависает l2tp подключение

Цитата:
Сообщение от dimajak Посмотреть сообщение
зависание интерфейса L2TP с удалённым офисом, которое работало десяток лет.

kerio 9.3
9.3 выпустили когда?..
в общем, "И дольше века длится день" (с) Ч. Айтматов
__________________
"Помогая ленивым людям, ты помогаешь им сесть на твою шею" Сян-Цзы
exchar вне форума   Ответить с цитированием Вверх
Ответ


Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход


Текущее время: 08:27. Часовой пояс GMT +3.


Powered by vBulletin® Version 3.8.12 by vBS
Copyright ©2000 - 2019, vBulletin Solutions Inc. Перевод: zCarot
© Kerio-rus.ru
Фонарёвка: всё о фонарях